Re: __clone() implementation

From: Date: Mon, 02 Feb 2004 20:15:37 +0000
Subject: Re: __clone() implementation
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-7492@lists.php.net to get a copy of this message
On 2 Feb 2004 at 21:57, Andi Gutmans wrote: > Because it's a good way of retrieving the to-be-cloned object (no behind > the scenes magic), and in my opinion, it's cleaner because everyone's clone > functions will look the same and it'll make it easier to understand them. > Why do you care so much if it's called $that or $foobar? > What is important is that the problems with clone are fixed (almost). And > you now have a consistent way of calling the parent clone method if you > choose to. I like the new way very much but I dislike that PHP tells me how to name a function parameter. __set() and __get(), for instance, do not force fixed argument names either, do they? Some people use their own naming convention for parameters and will be confused when they can't keep it for __clone(). For example many beginners like to use names in their native language. I'm sure there will be many people complaining if this stays as it is. I still don't see the need for a fixed name... it is like forcing every exception class to have the word 'exception' in their name, just for consistency.... -- Ferdinand Beyer <fb@fbeyer.com>

« previous php.internals (#7492) next »