Re: __clone() implementation

From: Date: Mon, 02 Feb 2004 21:40:32 +0000
Subject: Re: __clone() implementation
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-7495@lists.php.net to get a copy of this message
At 09:15 PM 2/2/2004 +0100, Ferdinand Beyer wrote:
I like the new way very much but I dislike that PHP tells me how to name a function parameter. __set() and __get(), for instance, do not force fixed argument names either, do they? Some people use their own naming convention for parameters and will be confused when they can't keep it for __clone(). For example many beginners like to use names in their native language. I'm sure there will be many people complaining if this stays as it is. I still don't see the need for a fixed name... it is like forcing every exception class to have the word 'exception' in their name, just for consistency....
OK, I'll think about it. Andi

« previous php.internals (#7495) next »