Re: 64-bit integers and 64-bit string length patch is ready to be merged
| From: | Anatol Belski | Date: | Fri, 22 Aug 2014 08:56:59 +0000 |
| Subject: | Re: 64-bit integers and 64-bit string length patch is ready to be merged | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-76793@lists.php.net to get a copy of this message | ||
Moin,
On Thu, August 21, 2014 19:23, Dmitry Stogov wrote:
> Hi,
>
>
> Thanks to Anatol and Pierre the 64-bit patch is ready
> https://github.com/weltling/php-src
>
>
> I made quick code review and don't see any technical problems now.
>
>
> The performance and memory consumption difference is negligible. see
>
> https://docs.google.com/spreadsheets/d/1PD4oiiXz6B0JbeZYnUSat5fHoq3_jAiCeI
> 2cGHJ3UtQ/edit#gid=0
>
>
> The patch breaks one test on 32-bit Linux:
> ext/date/tests/bug53437_var3.phpt (seems to be a bogus test and wrong
> behavior in php5.6 and below) and one test on 64-bit Linux:
> ext/standard/tests/array/array_pad_variation2.phpt (has to be analyzed)
>
> The only thing that I don't like is a massive renaming described here
>
> https://wiki.php.net/rfc/size_t_and_int64_next#semantical_macro_renamings
>
>
> IS_LONG -> IS_INT
> Z_LVAL -> L_IVAL
> etc
>
> On one hand using INT may be more consistent, on the other hand it's
> going to break habits and make addition headache for merging from php-5 (I
> know, phpng already made problems)
>
> I'm not sure how to proceed. If I'm alone, lets go ahead with new names.
> If
> some others prefer old names we will probably need voting.
>
> Despite of renaming, I would like to see this patch in master ASAP.
>
>
> Thanks. Dmitry.
>
>
the patch is merged by now as is. I greatefuly thank all the supporters,
especially Nikita for the idea on how to join phpng and str-size_and_int64
with minimal loss and Dmitry for the closer look. I think it's feasible
solving the naming issues with Andrea's or some separate RFC.
Regards
anatol