Re: New globals for PUT and DELETE
| From: | Rowan Collins | Date: | Tue, 14 Oct 2014 18:08:37 +0000 |
| Subject: | Re: New globals for PUT and DELETE | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-78044@lists.php.net to get a copy of this message | ||
On 14/10/2014 14:57, Kris Craig wrote:
It's not supposed to functionally differ. It's supposed to create some better consistency and make it easier for devs to differentiate between different REST methods when retrieving data. If REQUEST_METHOD is PUT, then I can set the parsed params to the value of $_PUT. The aliases match the methods used, making the code that much more readable and scalable.For that to be consistent, you would need to unset $_GET on POST requests, which would be ... unhelpful. GET and POST are simply the *wrong names*. Naming more things based on them is just engraining a mistake. -- Rowan Collins [IMSoP]