[RFC][Discussion] In Operator

From: Date: Fri, 20 Feb 2015 12:54:26 +0000
Subject: [RFC][Discussion] In Operator
Groups: php.internals 
Request: Send a blank email to internals+get-83293@lists.php.net to get a copy of this message
Hi internals, "In Operator" is now in discussion phase. > This RFC adds a new in operator which simplifies contains checks for strings and arrays. > Currently, we have to usein_array($needle, $haystack, true) or strpos($haystack, $needle) !== > false. > These functions have a inconsistent parameter order, so it's hard to remember which is the > right one > for each. The in operator makes these checks way more readable. Additionally, it also works for > Traversable. https://wiki.php.net/rfc/in_operator Question: The timline says "Line up any remaining RFCs that target PHP 7.0.", does that mean RFCs have to start voting on Mar 15 or should the vote end there? It would really make sense to vote on this RFC after there has been a vote on https://wiki.php.net/rfc/context_sensitive_lexer. Regards, Niklas

« previous php.internals (#83293) next »