Re: [RFC][Discussion] In Operator
| From: | Johannes Schlüter | Date: | Fri, 20 Feb 2015 15:55:09 +0000 |
| Subject: | Re: [RFC][Discussion] In Operator | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-83314@lists.php.net to get a copy of this message | ||
On Fri, 2015-02-20 at 13:54 +0100, Niklas Keller wrote:
> Hi internals,
>
> "In Operator" is now in discussion phase.
>
> > This RFC adds a new in operator which simplifies contains checks for strings and arrays.
> > Currently, we have to usein_array($needle, $haystack, true) or strpos($haystack, $needle)
> > !== false.
> > These functions have a inconsistent parameter order, so it's hard to remember which
> > is the right one
> > for each. The in operator makes these checks way more readable. Additionally, it also
> > works for Traversable.
>
> https://wiki.php.net/rfc/in_operator
| It uses strict comparison (===) for array values / instances of
| Traversable
This might be nice but is inconsistent with other parts of the language
like switch statements. I think inconsistency is worse than this
inconvenience.
johannes