Re: Studlycaps and MySQLi
| From: | Ilia Alshanetsky | Date: | Tue, 23 Mar 2004 15:36:55 +0000 |
| Subject: | Re: Studlycaps and MySQLi | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-8677@lists.php.net to get a copy of this message | ||
First of I do not believe it is a good idea this late in the release cycle to
change the API of the SQLite's OO interface, especially without a fallback
mechanism. This change obsoletes all existing articles, tutorials, etc... and
will definitely break scripts of early adopters, which would certainly not
help further adoption of PHP and SQLite.
I still maintain that studlyCaps is a poor choice for a naming convention, but
that's another matter all together.
If this change does stick, could we at least add aliases to SQLite that would
allow the syntax (non-studlyCaps) to work.
Ilia