Re: Studlycaps and MySQLi
| From: | George Schlossnagle | Date: | Fri, 26 Mar 2004 15:35:59 +0000 |
| Subject: | Re: Studlycaps and MySQLi | ||
| References: | 1 2 3 4 5 6 7 8 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-8782@lists.php.net to get a copy of this message | ||
On Mar 26, 2004, at 10:30 AM, Stefan Walk wrote:
On Fri, Mar 26, 2004 at 07:05:15AM -0800, Rasmus Lerdorf wrote:No one is discussing changing the names of these functions. The standard being discussed is specifically limited to OO code, so please stop trying to take this discussion astray with such strawman arguments. GeorgeOn Fri, 26 Mar 2004, Stefan Walk wrote:Well, C is consistent in that it doesn't use underscores there. If no underscores at all would be used, i wouldn't complain either. But the way it is now is inconsistent... and using a different naming convention for "member functions" a.k.a. methods introduces new inconsistency. I know that it's not possible to kill all existing inconsistencies, but why introduce new ones?Oh, and the strpos/str_repeat inconsistency should be 'fixed' too, maybe make strpos an alias to str_pos or alike...So you are saying strlen() should be str_len() as well? If I ever see a patch to change that I'll hunt the person down and make them swallow an entire K&R C book. -Rasmus