Re: PHP 7.1 - Address PHPSadness #28?

From: Date: Wed, 16 Sep 2015 11:36:25 +0000
Subject: Re: PHP 7.1 - Address PHPSadness #28?
References: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20  Groups: php.internals 
Request: Send a blank email to internals+get-88229@lists.php.net to get a copy of this message
Hi Rowan, Le 16/09/2015 12:57, Rowan Collins a écrit :
However, I have still yet to see any use case where it would be necessary or useful to detect - at runtime, rather than in static analysis for debugging - that $i has never been initialised, vs it having been initialised to null.
I agree that it is not needed on local vars very often (maybe in some template systems...). But, even if it is used mostly as a replacement for array_key_exists() or property_exists(), it will improve readability and push devs away from isset(), which is quite positive. Regards François

« previous php.internals (#88229) next »