Re: PHP 7.1 - Address PHPSadness #28?

From: Date: Wed, 16 Sep 2015 16:23:38 +0000
Subject: Re: PHP 7.1 - Address PHPSadness #28?
References: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20  Groups: php.internals 
Request: Send a blank email to internals+get-88249@lists.php.net to get a copy of this message
Lester Caine wrote on 16/09/2015 16:48:
On 16/09/15 16:40, Rowan Collins wrote:
If the extract() was being used to make the view code more readable in the first place, the exists() defeats rather than assists in that objective, in my opinion.
My own interface with it has been via templating, where the layout is stored in a database and as elements are download any 'NULL' values either get replaced by a default, or ignored. It's not the best of coding practice, but it works ...
OK... and how would you use the exists() function in this framework, if it existed? How would you want an uninitialised variable to behave, other than in the same way as a NULL value?

« previous php.internals (#88249) next »