Re: Re: [RFC][Discuss] Arrow Functions

From: Date: Fri, 03 Feb 2017 19:18:10 +0000
Subject: Re: Re: [RFC][Discuss] Arrow Functions
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-98142@lists.php.net to get a copy of this message
Hi David, David Rodrigues wrote:
Hello folks! I just not understand why "function" should be abbreviated. It's about "how less character better"? I don't see it too much on PHP. I guess that is more simple keep what exists current "function", that all knows about (that should be better than the next example): $mapped = array_map(function($x) => $x + $y); // vs current: $mapped = array_map(function($x) use($y) { return $x + $y });
I feel the same way. It would be nice to have shorter syntax, but it sacrifices readability and familiarity here, and adds yet another new keyword. It also feels inconsistent… isn't "fn" just short for "function"? Why is it exclusive to the => syntax? Thanks. -- Andrea Faulds https://ajf.me/

« previous php.internals (#98142) next »