Re: New Class Proposal
| From: | Jason Perkins | Date: | Wed, 04 Dec 2002 23:29:40 +0000 |
| Subject: | Re: New Class Proposal | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-11363@lists.php.net to get a copy of this message | ||
On Wednesday, Dec 4, 2002, at 16:19 America/Chicago, Mika Tuupola wrote:
On Wed, 4 Dec 2002, Jason Perkins wrote:Cart::clear() doesn't do much in terms of keeping the method naming internally consistent given that Cart::remove() was the proposed method name of removing an item. Jason PerkinsHow about: Cart::remove_all()Which should be Cart::removeAll() or even better Cart::clear()