Re: New Class Proposal
| From: | Arnaud Limbourg | Date: | Thu, 05 Dec 2002 06:54:18 +0000 |
| Subject: | Re: New Class Proposal | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-11373@lists.php.net to get a copy of this message | ||
> >> Cart::remove_all()
> >
> > Which should be Cart::removeAll() or even better
> > Cart::clear()
>
> Cart::clear() doesn't do much in terms of keeping the method naming
> internally consistent given that Cart::remove() was the proposed method
> name of removing an item.
He was pointing th coding standards non-conformnace of remoave_all, following CS it gives removeAll
;))