Re: File Operation Again

From: Date: Mon, 30 Jul 2001 12:36:48 +0000
Subject: Re: File Operation Again
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-1146@lists.php.net to get a copy of this message
yavor shahpasov wrote: > > I hope this one comes through, I've renamed it to .txt. > > I also had an error in the example > > Valid criteria's right now are > FILE_CRITERIA_BIGGER > FILE_CRITERIA_SMALLER > FILE_CRITERIA_EQUAL > ( the above take parameters as 100 for bytes, 100KB for kilobytes, 100MB > 100GB) > FILE_CRITERIA_OLDER > FILE_CRITERIA_OLDER_MINUTES > FILE_CRITERIA_OLDER_DAYS > FILE_CRITERIA_OLDER_HOURS > FILE_CRITERIA_NEWER > FILE_CRITERIA_NEWER_* > (file name matching is not complete) To be really PEAR compliant these constants should be named FILE_OPERATION_CRITERIA_*. But why can't you just use strings for this? "bigger", "smaller", "equal" and so on is less typing, sort-of :-) - Stig

« previous php.pear.dev (#1146) next »