Re: File Operation Again
| From: | Yavor Shahpasov | Date: | Mon, 30 Jul 2001 13:17:29 +0000 |
| Subject: | Re: File Operation Again | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-1149@lists.php.net to get a copy of this message | ||
>> FILE_CRITERIA_NEWER_*
>> (file name matching is not complete)
>
> To be really PEAR compliant these constants should be named
> FILE_OPERATION_CRITERIA_*. But why can't you just use strings for
> this? "bigger", "smaller", "equal" and so on is less typing,
> sort-of
> :-)
>
> - Stig
Well I you could always define FILE_OPERATION_DELETE to be "delete" if that
would make it easier, but I was just following PEAR rules as in
PEAR::setErrorHandling(PEAR_ERROR_PRINT) :)
Changing the constants would not take too long FILE_ to FILE_OPERATION
yavor
--
The difference between a good man and a bad one is the choice of cause
William James