Re: File Operation Again
| From: | Stig S. Bakken | Date: | Mon, 30 Jul 2001 22:38:28 +0000 |
| Subject: | Re: File Operation Again | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-1172@lists.php.net to get a copy of this message | ||
Yavor Shahpasov wrote:
>
> >> FILE_CRITERIA_NEWER_*
> >> (file name matching is not complete)
> >
> > To be really PEAR compliant these constants should be named
> > FILE_OPERATION_CRITERIA_*. But why can't you just use strings for
> > this? "bigger", "smaller", "equal" and so on is less
> > typing, sort-of
> > :-)
> >
> > - Stig
>
> Well I you could always define FILE_OPERATION_DELETE to be "delete" if that
> would make it easier, but I was just following PEAR rules as in
> PEAR::setErrorHandling(PEAR_ERROR_PRINT) :)
> Changing the constants would not take too long FILE_ to FILE_OPERATION
The error handling constants would have been strings too, but I got this
weird idea of being able to combine them bit-wise.
- Stig