RE: [PEAR-DEV] Mail_Mbox
| From: | Lukas Smith | Date: | Sat, 28 Dec 2002 18:16:02 +0000 |
| Subject: | RE: [PEAR-DEV] Mail_Mbox | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-11893@lists.php.net to get a copy of this message | ||
> -----Original Message-----
> From: Eric [mailto:eric@ypass.net]
> Sent: Saturday, December 28, 2002 7:13 PM
> To: Lukas Smith
> Cc: 'Chandrashekhar Bhosle'; 'Bertrand Mansion';
roberto@desenvolve.com.br;
> pear-dev@lists.php.net
> Subject: RE: [PEAR-DEV] Mail_Mbox
>
>
>
> On Sat, 28 Dec 2002, Lukas Smith wrote:
>
>
> >
> > So this makes the naming a bit complicated.
> > I would therefore suggest naming the class something like
> > "Mail_[XXX]_Mbox" for now ... I don't like "Store" as suggested
earlier,
> > because that does not make it claer that the class can do more then
> > "store" aka "add".
>
> The reason store was suggested is because Mbox, maildir, maildir++,
and
> various other formats are commonly referred to as the "mail store."
With
> store being a noun, not verb, it makes more sense.
>
> Either way, as long as it's obvious what the class does, i'm fine with
any
> name. I just felt the need to clarify the previous suggestion.
Ok then "store" does make sense.
Therefore I propose "Mail_Store_Mbox" as the class name.
That way a more generic class could be added later under the name
"Mail_Store"
Regards,
Lukas