Net_IMAP: some considerations about the "PEAR Weekly News" article
| From: | Damian Alejandro Fernandez Sosa | Date: | Fri, 21 Feb 2003 01:06:50 +0000 |
| Subject: | Net_IMAP: some considerations about the "PEAR Weekly News" article | ||
| Groups: | php.pear.dev | ||
| Request: | Send a blank email to pear-dev+get-13529@lists.php.net to get a copy of this message | ||
in the "PEAR Weekly News for week ending 16 Feb 2003"
appears a consideration over my Net_IMAP class which is:
"Net_IMAP:
Damian Alejandro Fernandez Sosa is developing an userland implementation
of IMAP protocol which provides IMAP access to people that dont have
IMAP support compiled."
I'd want to thanks Mika Tuupola and Pierre-Alain Joye for writing this
but I want to make some considerations about the class:
* The class is NOT only to "provide IMAP access to people
that dont have IMAP support compiled" it is to bring the
full potential of IMAP4Rev1 to PHP and PEAR. php's IMAP
implementation usues an OLD library (c-client) to provide IMAP,POP
and NNTP access. that library is optimized in COMPATIBILITY between
the 3 protocols and not in implemmenting the full IMAP specs.
* The imap support in php is NOT complete:
How can you search A message by The date that message was sent?
(SENTON != ON )
Searching my Custom Headers?
by UID?
by smaller than XXX bytes messages?
and larger? (the PHP IMAP's Search implementation is based on
RFC1176 (IMAP2) my class in RFC2060 (IMAP4Rev1).)
* In php you can only SET an ACL, my class allows to get an ACL,
Set, list my own acl's and list myrights in a mailbox.
* that about the Cyrus extensions?
* ACAP (RFC2245) and IMSP are easy to add to My class (allowing to
create and manage configuration, address books, calendars
and notes in a IMAP store)
Once the Net_IMAPProtocol class's methods are stable, I was Thinking in
make a PECL extension with the cmdXXXX methods that return the same
values allowing to have the best of the 2 worlds the PHP-only
implemmentation and the PECL extension. (SPEED and full protocol
Support)
Comments? / Ideas?