Re: Package Proposal: Vcard_Parse
| From: | Bertrand Mansion | Date: | Wed, 19 Mar 2003 16:02:03 +0000 |
| Subject: | Re: Package Proposal: Vcard_Parse | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-14463@lists.php.net to get a copy of this message | ||
le 19/03/03 16:28, Paul M Jones à pjones@ciaweb.net a écrit :
> On Tuesday, Mar 18, 2003, at 16:34 US/Central, Bertrand Mansion wrote:
>
>>>> 2. Create a writer in complement to the parser.
>>>
>>> Am working on that now, in conjunction with a vCard "contacts"
>>> sub-application for my Phorecast project. It'll probably be a
>>> separate
>>> class, as there are good vCard-writers out there now, and choice is
>>> good.
>>
>> If you are currently working on it now, I don't see the need to have a
>> parser and a writer as 2 different classes.
>
> Although I'm working on it, it's going to take a bit more time (a
> month?) to get it really the way I want it. Would like to make the
> parser available sooner rather than later (so as to get something
> useful out there).
>
> In addition, the vCard builder (to collate elements into a vCard) and a
> writer (to add/chg/del cards from a text file) are different enough in
> purpose that I think they ought to be different classes; the number of
> methods will quickly increase into incomprehensibility. But I may be
> wrong, and I'll know for sure in a month or so (after I've done it ;-).
>
>
>> Make sure it writes vCard in 2 and 3.0 formats though... ;)
>
> Of course. :-)
>
>
>> X500 doesn't mean anything for me, it's too cryptic.
>
> Fair enough.
>
>
>> I guess you will have to choose and propose a name like those:
>> - Contact_vCard
>> - Address_vCard
>> - File_vCard
>>
>> The logic behind the name is that we have a Genealogy_Gedcom and a
>> Spreadsheet_Excel_Writer. You see that the prefix actually defines the
>> domain it is mostly used in. Excel is a spreadsheet app while Gedcom
>> is a
>> common format for genealogy files. vCard is a common format for
>> dealing with
>> contacts or addresses...
>>
>> IMO, File is too general.
>
> Agreed, although others seem to think it's OK. Contact_Vcard_* it is,
> then, unless I hear otherwise.
>
> Given the above, and the quality of the code as it stands, do you
> (Bertrand) feel comfortable assigning your vote? Or does it still need
> tweaking?
>
> Thanks for all your good input.
No worries, +1
Bertrand Mansion
Mamasam