Re: Re[4]: [PEAR-DEV] previos message
| From: | Martin Jansen | Date: | Sun, 16 Sep 2001 08:09:29 +0000 |
| Subject: | Re: Re[4]: [PEAR-DEV] previos message | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-1943@lists.php.net to get a copy of this message | ||
On Sun, 16 Sep 2001 02:30:50 +0300 (EET DST), Mika Tuupola wrote:
>On Sun, 16 Sep 2001, Martin Jansen wrote:
>
>> According to this rule I don't know anymore if Image_Common
>> is an appropriate name for it. Perhaps Image_GDConvert would
>> be better since converting images (that's the purpose of your
>> class, isn't it?) isn't what I would call common image operations.
>
> I think the idea of the class is to provide common oo interface
> to some image related functions (opening, saving, converting
> between formats). By calling the class Image_GDConvert you
> would limit it to be only wrapper for GD which I dont find
> too usefull (only usefull part would be getting rid of different
> ImageCreateFromXXX() and imageXXX() functions.
>
> If we would call the class Image_Convert it would leave room
> to use other additional graphics libraries such as imLib.
I have no problem with Image_Convert instead of Image_GDConvert
(much more easy to write btw).
- Martin