Re: Re[4]: [PEAR-DEV] previos message
| From: | Mika Tuupola | Date: | Thu, 01 Jan 1970 00:00:00 +0000 |
| Subject: | Re: Re[4]: [PEAR-DEV] previos message | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-1940@lists.php.net to get a copy of this message | ||
On Sun, 16 Sep 2001, Martin Jansen wrote:
> According to this rule I don't know anymore if Image_Common
> is an appropriate name for it. Perhaps Image_GDConvert would
> be better since converting images (that's the purpose of your
> class, isn't it?) isn't what I would call common image operations.
I think the idea of the class is to provide common oo interface
to some image related functions (opening, saving, converting
between formats). By calling the class Image_GDConvert you
would limit it to be only wrapper for GD which I dont find
too usefull (only usefull part would be getting rid of different
ImageCreateFromXXX() and imageXXX() functions.
If we would call the class Image_Convert it would leave room
to use other additional graphics libraries such as imLib. This
would make the class much more usefull since you would have
common api between these.
I dont think Image_Common is appropriate name either since
"common" should be a base class which to me means much more that
opening, saving and converting between formats. Then again
if the class will later include other functions such as scaling,
getimagesize etc etc. Image_Commong might be a good name after
all.
--
Mika Tuupola http://www.appelsiini.net/~tuupola/