Re: Proposal: Services_ExchangeRates

From: Date: Sat, 30 Aug 2003 01:51:44 +0000
Subject: Re: Proposal: Services_ExchangeRates
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-20841@lists.php.net to get a copy of this message
Hi Marshall, +1 for the package. It's really nice :) Please change all the error codes so that their prefix is: SERVICES_EXCHANGERATES_ERROR_ This is not yet documented as a requirement, and I'll fix that in the pearweb docs for future packages. Greg Marshall Roch wrote:
I've changed the name of my currency conversion package yet again, this time to Services_ExchangeRates. I think that makes more sense than just Services_Exchange, since everyone knows what "exchange rates" are, but might not associate "exchange" alone with that. I've incremented the version number to 0.4, with the following changes: * Implemented conditional GETs with HTTP_Request and Cache_Lite * Improved file retrieval/caching methods in Common.php * Allowed default settings to be overridden with $options parameter in the constructor * Added dependency on HTTP_Request * Added dependency on Cache_Lite * Removed dependency on Cache Only 2 more +1s needed. :) -- Marshall Roch


« previous php.pear.dev (#20841) next »