[PEPr] Comment on Math::Math_Finance

From: Date: Mon, 28 Mar 2005 19:19:43 +0000
Subject: [PEPr] Comment on Math::Math_Finance
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-36903@lists.php.net to get a copy of this message
Louis Mullie (http://pear.php.net/user/louism) has commented on the proposal for Math::Math_Finance. Comment: Hi, Sounds very useful. A few little things : - You should have constants for payment types (FINANCE_PAY_END = 0, FINANCE_PAY_START = 1 or the like) - Same thing for the "Type of day count basis" - Class "FunctionParameters" should be named "Math_Finance_FunctionParameters" - The Newtonraphson.php file should only be included when needed. - Your docblocks should have the @static tag to show that all the methods are static. - Also, I'm not sure if you should follow either the PEAR standard for the names or the excel API names. I think you could keep the names as they are. Appart from those few issues, this is a very nice class and it'd be a great addition to PEAR. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=225 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#36903) next »