Re: PHP_Compat, signature changes
| From: | Ian Eure | Date: | Sat, 28 May 2005 20:04:55 +0000 |
| Subject: | Re: PHP_Compat, signature changes | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-37859@lists.php.net to get a copy of this message | ||
On Saturday 28 May 2005 07:39 am, Aidan Lister wrote:
> Hello devs,
>
> There are a number of functions for which the function signature has
> changed. For example, microtime now has an added boolean, mkdir has a
> recursive switch, etc.
>
> (snip)
>
> If you have any suggestions, please let me know.
>
If you depend on the APD extension (http://pecl.php.net/package/apd), it can
rename functions. So you could rename the internal function to e.g.
_native_foofunc(), and replace it with the PHP implementation.
Attachment: [application/pgp-signature]
Attachment: [application/pgp-signature]