Problem with Cache Package installation
| From: | Naoki Shima | Date: | Fri, 19 Apr 2002 09:03:40 +0000 |
| Subject: | Problem with Cache Package installation | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-5663@lists.php.net to get a copy of this message | ||
I have tried to install Cache package using pear install, but it gave me
error
stating that there is no package.xml
as:
# pear install http://pear.php.net/get/Cache
downloading http://pear.php.net/get/Cache ...
...done: 26,775 bytes
warning : you are using an archive with an old format
no package.xml file after extracting the archive
When I downloaded and extracted http://pear.php.net/get/Cache
It creates PEAR_Cache-1.2 Directory and its contents(without package.xml)
and following path and file under my pear directory.
C:/home/php/pear/Cache/pea28.tmp/package.xml
so it actually is
/usr/local/php/C:/home/php/pear/Cache/pea28.tmp/package.xml
I moved this package.xml into PEAR_Cache-1.2/ and tar -zcvf 'ed it, and then
did # pear install Cache.tgz
It failed to copy file inside the Cache/Container directory.
I think the problem is that backslash is used where it's supposed to be
slash for *unix system like my FreeBSD box.
for example,
<file role="php" baseinstalldir="Cache"
md5sum="b672273d1681ba296d2234653e46
abc1">Container\dbx.php</file>
needs to be
<file role="php" baseinstalldir="Cache"
md5sum="b672273d1681ba296d2234653e46
abc1">Container/dbx.php</file>
Best regards,
Naoki Shima