Re: File Naming Convention
| From: | bertrand Gugger | Date: | Tue, 07 Dec 2004 07:55:04 +0000 |
| Subject: | Re: File Naming Convention | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.pear.qa |
| Request: | Send a blank email to pear-qa+get-2119@lists.php.net to get a copy of this message | ||
Justin Patrin wrote:
Net/Monitor/Service/HTTP.php holds the class Net_Monitor_Service_HTTP. Similarly if you want to load the class Net_Monitor_Service_HTTP you can require_once Net/Monitor/Service/HTTP.php'. I don't understand why you're asking. What kind of different naming scheme would you use? From now up no other system as this one.If I make a class A_B_C then it needs to be in A/B/C.php if I like future user to may use __autoload() with it. All that is a OO nonsense. Should we say OFO: Object File Oriented ? or perhaps FOO ? Thanks, Justin, I can now understand why PHP scripters fear this __autoload() so much. à+ -- bertrand Gugger (toggg)