Re: File Naming Convention

From: Date: Tue, 07 Dec 2004 08:34:27 +0000
Subject: Re: File Naming Convention
References: 1 2 3 4 5 6 7 8  Groups: php.pear.qa 
Request: Send a blank email to pear-qa+get-2122@lists.php.net to get a copy of this message
Bertrand Gugger wrote:
Justin Patrin wrote:
Net/Monitor/Service/HTTP.php holds the class Net_Monitor_Service_HTTP. Similarly if you want to load the class Net_Monitor_Service_HTTP you can require_once Net/Monitor/Service/HTTP.php'. I don't understand why you're asking. What kind of different naming scheme would you use?
From now up no other system as this one. If I make a class A_B_C then it needs to be in A/B/C.php if I like future user to may use __autoload() with it. All that is a OO nonsense.
__autoload() is a function that is called in PHP5 if a class does not exist. Its a last chance at including the necessary code. Obviously you need to be able to determine the location of the file in which the class resides from the classname. I have a hard time seeing the nonsense.
Should we say OFO: Object File Oriented ? or perhaps FOO ? Thanks, Justin, I can now understand why PHP scripters fear this __autoload() so much.
err? maybe we should just leave this list to the trolls and have real discussions somewhere else? regards, Lukas

« previous php.pear.qa (#2122) next »