(really: hungarian) Re: [PHP-CVS] cvs: php4 /pear/Date Calc.php Calendar.php

From: Date: Sat, 14 Oct 2000 22:51:46 +0000
Subject: (really: hungarian) Re: [PHP-CVS] cvs: php4 /pear/Date Calc.php Calendar.php
References: 1 2 3 4  Groups: php.pear 
Request: Send a blank email to php-pear+get-376@lists.php.net to get a copy of this message
At 5:30 PM -0400 10-14-2000, Chuck Hagenbuch wrote:
Quoting Monte Ohrt <monte@ispi.net>:
This can be done.. although how important is it? Is this a rigid PEAR code style that should be followed? My personal preference is to use last_day_of_month instead of lastDayOfMonth, it just easier to read when the words aren't all run together.
Well, it's something that's in the current standards doc, and I happen to think it's a good idea - it's just consistency. If we make sure that the entire PEAR class tree follows the same method naming conventions, then it'll be easier for people to remember what methods are called. Code using PEAR stuff will also look more consistent, also. That's my argument for. Other thoughts? -chuck
Consistent with other PEAR code, yes. I'm curious why hungarian was chosen for PEAR when all the functions in PHP itself are written with names containing underscores. If consistency is the goal, why not use underscore name in PEAR, too? -- Paul DuBois, paul@snake.net

« previous php.pear (#376) next »