PDO* naming convention

From: Date: Sat, 13 Nov 2004 22:38:50 +0000
Subject: PDO* naming convention
Groups: php.pecl.dev 
Request: Send a blank email to pecl-dev+get-1620@lists.php.net to get a copy of this message
There is small incosistency in naming convention of PDO* packages. Say, we have PDO package, whose name, according to package.xml is PDO. Then it produces extension with filename starting with "pdo" (lower case). All other PDO_* packages (except pdo_mysql), are named with uppercase and depend on extension named pdo. They also produce lower-case named extension files. As this probably isn't such a big issue, it would be nice if this was clarified - how these should be named? PDO_* or pdo_* ? Personally I'd prefer the latter, but I'm not the one who's in charge here :) -- http://www.mysza.eu.org/ | Everybody needs someone sure, someone true, PLD Linux developer | Everybody needs some solid rock, I know I do.

« previous php.pecl.dev (#1620) next »