Re: [PHP4BETA] New function chrcount (diff attached)
| From: | Zeev Suraski | Date: | Tue, 25 Apr 2000 09:52:57 +0000 |
| Subject: | Re: [PHP4BETA] New function chrcount (diff attached) | ||
| References: | 1 | Groups: | php.version4 |
| Request: | Send a blank email to php-version4+get-14047@lists.php.net to get a copy of this message | ||
I'm in favour of this; We have several functions (like addslashes()) that
go all the way back to PHP/FI 2.0, and don't conform to the standard PHP
naming scheme.
Zeev
On Tue, 25 Apr 2000, Cynic wrote:
> Oh, and BTW, would it be too much if I beg for standardized
> aliases to those functions that don't comply with the said
> standard? Like add_slashes - addslashes? This may be way off,
> but I find it easier to memorize all the function names if
> they are
> str_replace, str_str, str_to_upper, nl_to_br, str_parse
> instead
> str_replace, strstr, strtoupper, nl2br, parse_str.
>
> (The same principle would apply for all functions, not only
> string ones.)
>
> This, of course, has the lowest priority I'm able to think
> of, but would be definitely very useful.
>
> At 22:45 24.4.2000 +0300, Andi Gutmans wrote the following:
> --------------------------------------------------------------
> >We are trying to standardize function names now, and as you mentioned we use underscores.
> >So this function should be called something like char_count() or count_chars().
> >
> >Andi
> >
> >At 08:05 PM 4/24/00 +0200, Cynic wrote:
> >>I like when function names have a system. Most PHP function
> >>name have words separated by underscore. Otherwise it's
> >>confusing ('is it addslashes or add_slashes?'). So, if you
> >>commit this patch, it'd be nice if the function was named
> >>maybe char_count.
> >>
> >>
> >>At 13:59 24.4.2000 -0400, Peter Kovacs wrote the following:
> >>--------------------------------------------------------------
> >> >I've created a new function chrcount (count_chars was already taken, and
> >> >count_char is too similar) which finds the number of times a character
> >> >appears in a string.
> >> >
> >> >Let me know what you all think.
> >> >
> >> >Peter
> >> >
> >> >--------------------------------------------------
> >> >Peter D. Kovacs KnowPost.com LLC
> >> >Lead Engineer peter@knowpost.com
> >> >--------------------------------------------------
> >> >
> >> >--
> >> >PHP 4.0 Beta Mailing List
> >> ><http://www.php.net/version4/>
> >> >To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net
> >> >For additional commands, e-mail: php4beta-help@lists.php.net
> >> >To contact the list administrators, e-mail: php4beta-admin@lists.php.net
> >>------end of quote------
> >>
> >>
> >>____________________________________________________________
> >>Cynic:
> >>
> >>A member of a group of ancient Greek philosophers who taught
> >>that virtue constitutes happiness and that self control is
> >>the essential part of virtue.
> >>
> >>cynic@mail.cz
> >>ICQ: 2808 2505
> >>
> >>
> >>
> >>
> >>
> >>
> >>--
> >>PHP 4.0 Beta Mailing List
> >><http://www.php.net/version4/>
> >>To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net
> >>For additional commands, e-mail: php4beta-help@lists.php.net
> >>To contact the list administrators, e-mail: php4beta-admin@lists.php.net
> >
> >---
> >Andi Gutmans <andi@zend.com>
> >http://www.zend.com/
> >
> >--
> >PHP 4.0 Beta Mailing List
> ><http://www.php.net/version4/>
> >To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net
> >For additional commands, e-mail: php4beta-help@lists.php.net
> >To contact the list administrators, e-mail: php4beta-admin@lists.php.net
> >
> ------end of quote------
>
>
> ____________________________________________________________
> Cynic:
>
> A member of a group of ancient Greek philosophers who taught
> that virtue constitutes happiness and that self control is
> the essential part of virtue.
>
> cynic@mail.cz
> ICQ: 2808 2505
>
>
>
>
>
>
>
--
Zeev Suraski <zeev@zend.com>
http://www.zend.com/