Re: [PHP4BETA] New function chrcount (diff attached)
| From: | Peter Kovacs | Date: | Mon, 24 Apr 2000 20:05:21 +0000 |
| Subject: | Re: [PHP4BETA] New function chrcount (diff attached) | ||
| References: | 1 | Groups: | php.version4 |
| Request: | Send a blank email to php-version4+get-13990@lists.php.net to get a copy of this message | ||
Okay. My only concern was making it too similar to the existing and
(somewhat) unrelated function count_chars. I've renamed it to
count_char. The diff is attached.
Peter
On Mon, 24 Apr 2000, Andi Gutmans wrote:
> We are trying to standardize function names now, and as you mentioned we
> use underscores. So this function should be called something like
> char_count() or count_chars().
>
> Andi
>
> At 08:05 PM 4/24/00 +0200, Cynic wrote:
> >I like when function names have a system. Most PHP function
> >name have words separated by underscore. Otherwise it's
> >confusing ('is it addslashes or add_slashes?'). So, if you
> >commit this patch, it'd be nice if the function was named
> >maybe char_count.
> >
> >
> >At 13:59 24.4.2000 -0400, Peter Kovacs wrote the following:
> >--------------------------------------------------------------
> > >I've created a new function chrcount (count_chars was already taken, and
> > >count_char is too similar) which finds the number of times a character
> > >appears in a string.
> > >
> > >Let me know what you all think.
> > >
> > >Peter
> > >
> > >--------------------------------------------------
> > >Peter D. Kovacs KnowPost.com LLC
> > >Lead Engineer peter@knowpost.com
> > >--------------------------------------------------
> > >
> > >--
> > >PHP 4.0 Beta Mailing List
> > ><http://www.php.net/version4/>
> > >To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net
> > >For additional commands, e-mail: php4beta-help@lists.php.net
> > >To contact the list administrators, e-mail: php4beta-admin@lists.php.net
> >------end of quote------
> >
> >
> >____________________________________________________________
> >Cynic:
> >
> >A member of a group of ancient Greek philosophers who taught
> >that virtue constitutes happiness and that self control is
> >the essential part of virtue.
> >
> >cynic@mail.cz
> >ICQ: 2808 2505
> >
> >
> >
> >
> >
> >
> >--
> >PHP 4.0 Beta Mailing List
> ><http://www.php.net/version4/>
> >To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net
> >For additional commands, e-mail: php4beta-help@lists.php.net
> >To contact the list administrators, e-mail: php4beta-admin@lists.php.net
>
> ---
> Andi Gutmans <andi@zend.com>
> http://www.zend.com/
>
> --
> PHP 4.0 Beta Mailing List <http://www.php.net/version4/>
> To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net
> For additional commands, e-mail: php4beta-help@lists.php.net
> To contact the list administrators, e-mail: php4beta-admin@lists.php.net
>
>
--------------------------------------------------
Peter D. Kovacs KnowPost.com LLC
Lead Engineer peter@knowpost.com
--------------------------------------------------