Problems compiling Beta2 and CVS with Apache 1.3.9 on Suse Linux

From: Date: Sun, 22 Aug 1999 17:25:21 +0000
Subject: Problems compiling Beta2 and CVS with Apache 1.3.9 on Suse Linux
References: 1  Groups: php.version4 
Request: Send a blank email to php-version4+get-3641@lists.php.net to get a copy of this message
Hi all, i'm running into problems compiling php4 Beta 2 as well as a fresh CVS copy with Apache 1.3.9 on Suse Linux 6.2. The error message is: gcc -rpath /usr/lib -rpath /usr/local/mysql/lib/mysql -shared -o libproxy.so mod_proxy.lo proxy_cache.lo proxy_connect.lo proxy_ftp.lo proxy_http.lo proxy_util.lo gcc: unrecognized option `-rpath' gcc: unrecognized option `-rpath' /usr/lib: file not recognized: Is a directory make[4]: *** [libproxy.so] Error 1 make[3]: *** [all] Error 1 make[2]: *** [subdirs] Error 1 make[2]: Leaving directory `/web/src/apache_1.3.9/src' make[1]: *** [build-std] Error 2 make[1]: Leaving directory `/web/src/apache_1.3.9' make: *** [build] Error 2 Even if this points to some Apache problems, it is due to PHP, as Apache compiles fine without activating PHP4. My PHP4 configure line is: CFLAGS="-O6 -mpentium -mstack-align-double -fomit-frame-pointer" ./configure --with-apache=../apache_1.3.9 --with-mysql --with-zlib --with-imap --with-ttf --with-xml --with-wddx --enable-track-vars and for Apache it is: CFLAGS="-O6 -mpentium -mstack-align-double -fomit-frame-pointer" ./configure --prefix=/usr/local/apache --enable-module=most --enable-shared=max --activate-module=src/modules/php4/libphp4.a I think i'm running into the same problem here as with a dev version of 3.11, which Rasmus was able to fix very quickly. Michael

« previous php.version4 (#3641) next »