#50205 [Opn->Bgs]: Can't start Apache 2.2.14 with PHP 5.2.11
| From: | pajoye@php.net | Date: | Mon, 23 Nov 2009 17:03:35 +0000 |
| Subject: | #50205 [Opn->Bgs]: Can't start Apache 2.2.14 with PHP 5.2.11 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-144970@lists.php.net to get a copy of this message | ||
ID: 50205
Updated by: pajoye@php.net
Reported By: vladmu at mail dot ru
-Status: Open
+Status: Bogus
Bug Type: Apache2 related
Operating System: win32 only - Windows XP
PHP Version: 5.2.11
-Assigned To:
+Assigned To: pajoye
New Comment:
Messing with DLLs, all these extensions require external DLL or clients
to be installed.
Previous Comments:
------------------------------------------------------------------------
[2009-11-23 17:00:57] vladmu at mail dot ru
So, I have disabled all extensions in php.ini - Apache 2.2.14 works
fine with PHP 5.2.11. Then I have enabled one
after another and found the following extensions that block the
working:
php_mssql.dll
php_oci8.dll
php_pdo_mssql.dll
php_pdo_oci.dll
php_pdo_oci8.dll
php_pdo_sqlite_external.dll
php_pspell.dll
php_sybase_ct.dll
But after I have uninstalled PHP 5.2.11 and install PHP 5.2.10 only
with extensions above and Apache 2.2.14 works fine with PHP 5.2.10 with
all "buggly" extensions enabled!
------------------------------------------------------------------------
[2009-11-21 11:13:19] pajoye@php.net
Disable all extensions in php.ini, check if it works. Then enable one
after another to see which one is failing. Many extensions (like DB
related) requires clients to be installed and we do not distribute them.
------------------------------------------------------------------------
[2009-11-20 19:31:25] vladmu at mail dot ru
I don't know this is the configuration error or something else but:
1. I have tried to install a snapshot and there is an equal bug.
2. I have tried to install an Apache 2.2.14 + PHP 5.2.10 and no any
errors have occured, and the same was with the Apache 2.2.14 + PHP
5.3.0
Therefore no bogus bug here, but really something wrong with your
5.2.11 libraries for WIndows. Please try to reproduce by yourself at
first before change the bug status to bogus.
------------------------------------------------------------------------
[2009-11-20 10:28:09] pajoye@php.net
Configuration error, ask on php-setup for support.
------------------------------------------------------------------------
[2009-11-18 14:23:53] jani@php.net
Please try using this snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
..and remove ALL old dlls and stuff before you do this..
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/50205
--
Edit this bug report at http://bugs.php.net/?id=50205&edit=1