#50270 [Opn->Fbk]: ldap_start_tls problem
| From: | jani@php.net | Date: | Tue, 24 Nov 2009 00:31:33 +0000 |
| Subject: | #50270 [Opn->Fbk]: ldap_start_tls problem | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-144994@lists.php.net to get a copy of this message | ||
ID: 50270
Updated by: jani@php.net
Reported By: jcarlos at dsi dot uclm dot es
-Status: Open
+Status: Feedback
Bug Type: LDAP related
Operating System: windows
PHP Version: 5.3.1
New Comment:
Check this if it helps:
http://marc.info/?l=php-windows&m=116127873321748&w=2
Previous Comments:
------------------------------------------------------------------------
[2009-11-23 11:35:29] jcarlos at dsi dot uclm dot es
$ds=ldap_connect($ldaphost);
if(!ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)){
print "No puedo establecer LDAPv3";
}else if (!ldap_set_option($ds, LDAP_OPT_REFERRALS, 0)){
print "No puedo establecer LDAP_OPT_REFERRALS";
}else if (!ldap_start_tls($ds)) { // <----- FAIL --------------
print "No puedo iniciar TLS ";
}else {
printf "OK!!!!";
}
}
------------------------------------------------------------------------
[2009-11-23 11:27:21] jcarlos at dsi dot uclm dot es
Description:
------------
My configuration (works perfect):
Apache/2.2.11 (Win32) mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.11
When i upgrade to:
Apache/2.2.11 (Win32) mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.3.1
ldap_start_tls problem
Reproduce code:
---------------
Warning: ldap_start_tls() [function.ldap-start-tls]: Unable to start
TLS: Connect error in
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50270&edit=1