#50270 [Com]: ldap_start_tls problem
| From: | jcarlos at dsi dot uclm dot es | Date: | Tue, 24 Nov 2009 10:44:19 +0000 |
| Subject: | #50270 [Com]: ldap_start_tls problem | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-145010@lists.php.net to get a copy of this message | ||
ID: 50270
Comment by: jcarlos at dsi dot uclm dot es
Reported By: jcarlos at dsi dot uclm dot es
Status: Feedback
Bug Type: LDAP related
Operating System: windows
PHP Version: 5.3.1
New Comment:
I have tested with:
Apache/2.2.14 (Win32) mod_ssl/2.2.14 OpenSSL/0.9.8k PHP/5.2.11 (works
fine)
Apache/2.2.14 (Win32) mod_ssl/2.2.14 OpenSSL/0.9.8k PHP/5.3.1 (same
error)
Previous Comments:
------------------------------------------------------------------------
[2009-11-24 09:11:21] jcarlos at dsi dot uclm dot es
Also, if I'm going back to php-5.2.11 works fine, but if I change the
php-5.3.1 not working
sorry for my english
------------------------------------------------------------------------
[2009-11-24 09:02:50] jcarlos at dsi dot uclm dot es
In the past, I always updated the php version and I have never had
problems.
I have in c:\openldap\sysconf\ the file ldap.conf
TLS_REQCERT never
TLS_CACERT C:\OpenLdap\sysconf\certs\cert_dom_uclm.pem
I have compiled Filezilla Server with support for ldap and It works
perfect now.
http://forum.filezilla-project.org/viewtopic.php?f=6&t=11146
It run with AD.
------------------------------------------------------------------------
[2009-11-24 00:31:33] jani@php.net
Check this if it helps:
http://marc.info/?l=php-windows&m=116127873321748&w=2
------------------------------------------------------------------------
[2009-11-23 11:35:29] jcarlos at dsi dot uclm dot es
$ds=ldap_connect($ldaphost);
if(!ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)){
print "No puedo establecer LDAPv3";
}else if (!ldap_set_option($ds, LDAP_OPT_REFERRALS, 0)){
print "No puedo establecer LDAP_OPT_REFERRALS";
}else if (!ldap_start_tls($ds)) { // <----- FAIL --------------
print "No puedo iniciar TLS ";
}else {
printf "OK!!!!";
}
}
------------------------------------------------------------------------
[2009-11-23 11:27:21] jcarlos at dsi dot uclm dot es
Description:
------------
My configuration (works perfect):
Apache/2.2.11 (Win32) mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.11
When i upgrade to:
Apache/2.2.11 (Win32) mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.3.1
ldap_start_tls problem
Reproduce code:
---------------
Warning: ldap_start_tls() [function.ldap-start-tls]: Unable to start
TLS: Connect error in
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50270&edit=1