#50270 [Com]: ldap_start_tls problem
| From: | jcarlos at dsi dot uclm dot es | Date: | Thu, 26 Nov 2009 10:54:12 +0000 |
| Subject: | #50270 [Com]: ldap_start_tls problem | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-145100@lists.php.net to get a copy of this message | ||
ID: 50270
Comment by: jcarlos at dsi dot uclm dot es
Reported By: jcarlos at dsi dot uclm dot es
Status: Feedback
Bug Type: LDAP related
Operating System: windows
PHP Version: 5.3.1
New Comment:
A little manual, for a easy configuration
INTEGRATING ACTIVE DIRECTORY WITH PHP-LDAP AND TLS
==================================================
My configuration:
Apache/2.2.14 (Win32) mod_ssl/2.2.14 OpenSSL/0.9.8k PHP/5.2.11
NOTE 1: At the momment, the versión 5.3.1 fail with tls
NOTE 2: This example works on windows, but in linux is similar
1) Download the Certificate X.509 (PEM format) from a web browser, I
used Firefox. I put the name webcert.crt
2) Create the folder c:\openldap\sysconf
3) Copy the file webcert.crt to c:\openldap\sysconf
4) With notepad you must create the file c:\openldap\sysconf\ldap.conf
file. The file contents:
TLS_REQCERT never
TLS_CACERT c:\openldap\sysconf\webcert.crt
5) The code:
<?php
$ldap="ldap.myDomain.com";
$usr="user@myDomain.com";
$pwd="mypassword";
$ds=ldap_connect($ldap);
$ldapbind=false;
if(ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3))
if(ldap_set_option($ds, LDAP_OPT_REFERRALS, 0))
if(ldap_start_tls($ds))
$ldapbind = @ldap_bind($ds, $usr, $pwd);
ldap_close($ds);
if(!$ldapbind)
echo "ERROR";
else
echo "OK";
?>
Previous Comments:
------------------------------------------------------------------------
[2009-11-24 10:44:19] jcarlos at dsi dot uclm dot es
I have tested with:
Apache/2.2.14 (Win32) mod_ssl/2.2.14 OpenSSL/0.9.8k PHP/5.2.11 (works
fine)
Apache/2.2.14 (Win32) mod_ssl/2.2.14 OpenSSL/0.9.8k PHP/5.3.1 (same
error)
------------------------------------------------------------------------
[2009-11-24 09:11:21] jcarlos at dsi dot uclm dot es
Also, if I'm going back to php-5.2.11 works fine, but if I change the
php-5.3.1 not working
sorry for my english
------------------------------------------------------------------------
[2009-11-24 09:02:50] jcarlos at dsi dot uclm dot es
In the past, I always updated the php version and I have never had
problems.
I have in c:\openldap\sysconf\ the file ldap.conf
TLS_REQCERT never
TLS_CACERT C:\OpenLdap\sysconf\certs\cert_dom_uclm.pem
I have compiled Filezilla Server with support for ldap and It works
perfect now.
http://forum.filezilla-project.org/viewtopic.php?f=6&t=11146
It run with AD.
------------------------------------------------------------------------
[2009-11-24 00:31:33] jani@php.net
Check this if it helps:
http://marc.info/?l=php-windows&m=116127873321748&w=2
------------------------------------------------------------------------
[2009-11-23 11:35:29] jcarlos at dsi dot uclm dot es
$ds=ldap_connect($ldaphost);
if(!ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)){
print "No puedo establecer LDAPv3";
}else if (!ldap_set_option($ds, LDAP_OPT_REFERRALS, 0)){
print "No puedo establecer LDAP_OPT_REFERRALS";
}else if (!ldap_start_tls($ds)) { // <----- FAIL --------------
print "No puedo iniciar TLS ";
}else {
printf "OK!!!!";
}
}
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/50270
--
Edit this bug report at http://bugs.php.net/?id=50270&edit=1