Bug #53149 [Opn->Fbk]: cURL extension crashes Apache server on start-up
Edit report at http://bugs.php.net/bug.php?id=53149&edit=1
ID: 53149
Updated by: cataphract@php.net
Reported by: Jondor at GMX dot net
Summary: cURL extension crashes Apache server on start-up
-Status: Open
+Status: Feedback
Type: Bug
Package: cURL related
Operating System: Windows 7
PHP Version: 5.3.3
Block user comment: N
New Comment:
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php
for Win32
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2010-10-25 13:54:54] Jondor at GMX dot net
Description:
------------
The Apache web server (version 2.2.17) on Windows 7 (32-bit) fails to
start whenever the cURL extension is enabled in php.ini. Disabling cURL
by commenting out the line "extension=php_curl.dll" fixes the problem.
All other extensions work fine.
In other words, installing the thread-safe PHP 5.3.3 for Apache on
Windows (php-5.3.3-Win32-VC6-x86.msi from windows.php.net) with all
default extensions crashed the web server on my system without any
sensible error message. The culprit was the cURL extension.
Expected result:
----------------
The PHP installer does not crash the web server, or at least exits with
an error message (in php-errors.log).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53149&edit=1
Thread (10 messages)