Bug #53149 [Csd->Bgs]: cURL extension crashes Apache server on start-up
Edit report at http://bugs.php.net/bug.php?id=53149&edit=1
ID: 53149
Updated by: pajoye@php.net
Reported by: Jondor at GMX dot net
Summary: cURL extension crashes Apache server on start-up
-Status: Closed
+Status: Bogus
Type: Bug
Package: cURL related
Operating System: Windows 7
PHP Version: 5.3.3
Block user comment: N
New Comment:
Not a bug in PHP > config error.
Previous Comments:
------------------------------------------------------------------------
[2010-10-27 11:33:00] Jondor at GMX dot net
I tried that already before submitting the original report. However,
meanwhile I identified the cause of the problem. In my system's search
path (%PATH% environment variable), the PHP directory was preceded by
another directory which also included the libeay32.dll that the cURL
extension depends on. Therefore it loaded that other version of
libeay32.dll which apparently isn't compatible with this PHP build.
Changing the search order fixed the problem.
------------------------------------------------------------------------
[2010-10-26 17:47:27] pajoye@php.net
Duplicated, you can try using the zip version please? Not the MSI.
Simply replace the php_curl.dll
------------------------------------------------------------------------
[2010-10-26 17:37:13] Jondor at GMX dot net
Tried to generate the backtrace using the Microsoft Debug Diagnostic
Tools. Couldn't get it to work for the Apache2.2 service (instructions
are for php.exe). I'm probably not savvy enough. Sorry.
------------------------------------------------------------------------
[2010-10-25 16:20:59] cataphract@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php
for Win32
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
------------------------------------------------------------------------
[2010-10-25 13:54:54] Jondor at GMX dot net
Description:
------------
The Apache web server (version 2.2.17) on Windows 7 (32-bit) fails to
start whenever the cURL extension is enabled in php.ini. Disabling cURL
by commenting out the line "extension=php_curl.dll" fixes the problem.
All other extensions work fine.
In other words, installing the thread-safe PHP 5.3.3 for Apache on
Windows (php-5.3.3-Win32-VC6-x86.msi from windows.php.net) with all
default extensions crashed the web server on my system without any
sensible error message. The culprit was the cURL extension.
Expected result:
----------------
The PHP installer does not crash the web server, or at least exits with
an error message (in php-errors.log).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53149&edit=1
Thread (10 messages)