Bug #53149 [Com]: cURL extension crashes Apache server on start-up
Edit report at https://bugs.php.net/bug.php?id=53149&edit=1
ID: 53149
Comment by: donatas at infosys dot lt
Reported by: Jondor at GMX dot net
Summary: cURL extension crashes Apache server on start-up
Status: Bogus
Type: Bug
Package: cURL related
Operating System: Windows 7
PHP Version: 5.3.3
Block user comment: N
Private report: N
New Comment:
I've found out that this problem with php_curl failing to start after updating php to 5.3
indeed came from libeay32.dll, the libeay32.dll that was in my Apache2/bin directory - never thought
to look there for any error.
Renaming/removing Apache2/bin/libeay32.dll and restarting Apache fixed the problem.
Previous Comments:
------------------------------------------------------------------------
[2011-02-08 16:57:14] info at cybrax dot com
Updating to PHP 5.2.17 Fixes this problem.
Thank you.
------------------------------------------------------------------------
[2011-02-08 16:52:10] pajoye@php.net
Right, many people seems to have issue to correctly set their PATH or where to put
DLLs. Not sure what we can do at this point. But there is no bug here.
------------------------------------------------------------------------
[2011-02-08 16:24:11] info at cybrax dot com
Same problem on Win XP SP3, Apache 2.2 and PHP 5 CuRL will crash apache on
startup, everything runs fine except when loading the curl extension.
Also tried to create a backtrace, sadly failed, Visual Studio debugger reports the
problem occures in php5ts.dll.
Tried Both MSI and ZIP, According to google this is a problem that more people
have.
------------------------------------------------------------------------
[2010-10-27 17:41:54] pajoye@php.net
Not a bug in PHP > config error.
------------------------------------------------------------------------
[2010-10-27 11:33:00] Jondor at GMX dot net
I tried that already before submitting the original report. However, meanwhile I identified the
cause of the problem. In my system's search path (%PATH% environment variable), the PHP
directory was preceded by another directory which also included the libeay32.dll that the cURL
extension depends on. Therefore it loaded that other version of libeay32.dll which apparently
isn't compatible with this PHP build. Changing the search order fixed the problem.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=53149
--
Edit this bug report at https://bugs.php.net/bug.php?id=53149&edit=1
Thread (10 messages)