Bug #53149 [Fbk->Opn]: cURL extension crashes Apache server on start-up
| From: | Jondor at GMX dot net | Date: | Tue, 26 Oct 2010 15:37:14 +0000 |
| Subject: | Bug #53149 [Fbk->Opn]: cURL extension crashes Apache server on start-up | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-155536@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=53149&edit=1
ID: 53149
User updated by: Jondor at GMX dot net
Reported by: Jondor at GMX dot net
Summary: cURL extension crashes Apache server on start-up
-Status: Feedback
+Status: Open
Type: Bug
Package: cURL related
Operating System: Windows 7
PHP Version: 5.3.3
Block user comment: N
New Comment:
Tried to generate the backtrace using the Microsoft Debug Diagnostic
Tools. Couldn't get it to work for the Apache2.2 service (instructions
are for php.exe). I'm probably not savvy enough. Sorry.
Previous Comments:
------------------------------------------------------------------------
[2010-10-25 16:20:59] cataphract@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php
for Win32
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
------------------------------------------------------------------------
[2010-10-25 13:54:54] Jondor at GMX dot net
Description:
------------
The Apache web server (version 2.2.17) on Windows 7 (32-bit) fails to
start whenever the cURL extension is enabled in php.ini. Disabling cURL
by commenting out the line "extension=php_curl.dll" fixes the problem.
All other extensions work fine.
In other words, installing the thread-safe PHP 5.3.3 for Apache on
Windows (php-5.3.3-Win32-VC6-x86.msi from windows.php.net) with all
default extensions crashed the web server on my system without any
sensible error message. The culprit was the cURL extension.
Expected result:
----------------
The PHP installer does not crash the web server, or at least exits with
an error message (in php-errors.log).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53149&edit=1