#19142 [NEW]: cannot load libphp4.so: undefined symbol: core_globals
| From: | red at tripany dot com | Date: | Wed, 28 Aug 2002 10:17:30 +0000 |
| Subject: | #19142 [NEW]: cannot load libphp4.so: undefined symbol: core_globals | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-18017@lists.php.net to get a copy of this message | ||
From: red@tripany.com
Operating system: Debian 2.2
PHP version: 4.2.2
PHP Bug Type: Apache related
Bug description: cannot load libphp4.so: undefined symbol: core_globals
Apache 1.3.26 is compiled and made as such:
./configure --prefix=/opt/httpd-1.3.26 --enable-module=expires
--enable-module=so --enable-module=auth_digest --enable-module=info
--enable-module=log_referer --enable-module=rewrite
--enable-module=vhost_alias
no errors during compile
Php is compiled and made as such:
./configure --prefix=/opt/php-4.2.2 --with-apxs=/opt/httpd-1.3.26/bin/apxs
--with-libdir=/usr/lib --with-gd --with-gettext --enable-safe-mofe
--with-config-file-path=/opt/httpd/conf --with-exec-dir=/usr/bin
--with-tiff-dir=/usr/lib --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib
--with-zlib-dir=/usr/lib --enable-magic-quotes --with-regex=system
--with-db --with-gdbm --enable-mbstring --enable-mbstr-enc-trans
--enable-track-vars --enable-wddx=shared --enable-mm=shared --enable-xml
--enable-ftp --enable-debug --with-ldap --with-mysql
no errors
doing a
/opt/httpd-1.3.26/bin/apachectl configtest
gives
Syntax error on line 235 of /opt/httpd-1.3.26/conf/httpd.conf:
Cannot load /opt/httpd-1.3.26/libexec/libphp4.so into server:
/opt/httpd-1.3.26/libexec/libphp4.so: undefined symbol: core_globals
and line 235 of httpd.conf is
LoadModule php4_module libexec/libphp4.so
Cheers
Robin
--
Edit bug report at http://bugs.php.net/?id=19142&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=19142&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=19142&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=19142&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=19142&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=19142&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=19142&r=support
Expected behavior: http://bugs.php.net/fix.php?id=19142&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=19142&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=19142&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=19142&r=globals