#19142 [Opn->Fbk]: cannot load libphp4.so: undefined symbol: core_globals
| From: | kalowsky@php.net | Date: | Wed, 28 Aug 2002 16:37:05 +0000 |
| Subject: | #19142 [Opn->Fbk]: cannot load libphp4.so: undefined symbol: core_globals | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18057@lists.php.net to get a copy of this message | ||
ID: 19142
Updated by: kalowsky@php.net
Reported By: red@tripany.com
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: Debian 2.2
PHP Version: 4.2.2
New Comment:
does this happen when just defining --with-apxs in the configure
script?
Previous Comments:
------------------------------------------------------------------------
[2002-08-28 06:17:29] red@tripany.com
Apache 1.3.26 is compiled and made as such:
./configure --prefix=/opt/httpd-1.3.26 --enable-module=expires
--enable-module=so --enable-module=auth_digest --enable-module=info
--enable-module=log_referer --enable-module=rewrite
--enable-module=vhost_alias
no errors during compile
Php is compiled and made as such:
./configure --prefix=/opt/php-4.2.2
--with-apxs=/opt/httpd-1.3.26/bin/apxs --with-libdir=/usr/lib --with-gd
--with-gettext --enable-safe-mofe
--with-config-file-path=/opt/httpd/conf --with-exec-dir=/usr/bin
--with-tiff-dir=/usr/lib --with-jpeg-dir=/usr/lib
--with-png-dir=/usr/lib --with-zlib-dir=/usr/lib --enable-magic-quotes
--with-regex=system --with-db --with-gdbm --enable-mbstring
--enable-mbstr-enc-trans --enable-track-vars --enable-wddx=shared
--enable-mm=shared --enable-xml --enable-ftp --enable-debug --with-ldap
--with-mysql
no errors
doing a
/opt/httpd-1.3.26/bin/apachectl configtest
gives
Syntax error on line 235 of /opt/httpd-1.3.26/conf/httpd.conf:
Cannot load /opt/httpd-1.3.26/libexec/libphp4.so into server:
/opt/httpd-1.3.26/libexec/libphp4.so: undefined symbol: core_globals
and line 235 of httpd.conf is
LoadModule php4_module libexec/libphp4.so
Cheers
Robin
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19142&edit=1