#19142 [Com]: cannot load libphp4.so: undefined symbol: core_globals

From: Date: Thu, 05 Sep 2002 00:14:49 +0000
Subject: #19142 [Com]: cannot load libphp4.so: undefined symbol: core_globals
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18459@lists.php.net to get a copy of this message
ID: 19142 Comment by: cmwade1@attbi.com Reported By: red@tripany.com Status: Closed Bug Type: Apache related Operating System: Debian 2.2 PHP Version: 4.2.2 New Comment: I have a simpler case: Compiling on Red Hat 7.2... Apache 1.3.26 is compiled like: ./configure --prefix=/usr/local/apache \ --enable-module=rewrite --enable-shared=rewrite \ --enable-module=proxy --enable-shared=proxy no errors, apache compiles and runs fine like this. php is compiled with: ./configure --with-mysql \ --with-apxs=/usr/local/apache/bin/apxs no errors during configure, make or install. However, when I go to start apache again, I get: Syntax error on line 207 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: core_globals bin/apachectl start: httpd could not be started line 207 is, of course: LoadModule php4_module libexec/libphp4.so Previous Comments: ------------------------------------------------------------------------ [2002-08-30 10:15:32] sniper@php.net You're really doing something wrong. This works just fine for me and couple of hundred other people out there.. :) Try with _clean_ sources. And with the proposed CORRECT paths..you still used /usr/lib where it should be /usr.. ------------------------------------------------------------------------ [2002-08-30 08:32:59] red@tripany.com My new configure line is: ./configure --prefix=/opt/php-4.2.2 --with-apxs=/opt/httpd-1.3.26/bin/apxs --with-gd --with-gettext --enable-safe-mofe --with-config-file-path=/opt/httpd/conf --with-exec-dir=/usr/bin --with-tiff-dir=/usr/lib --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-zlib --enable-magic-quotes --with-db --with-gdbm --enable-mbstring --enable-mbstr-enc-trans --enable-track-vars --enable-wddx=shared --enable-mm --enable-xml --enable-ftp --enable-debug --with-ldap --with-mysql And it's still giving the same error. Unfortunately, I can't do without the location of apxs, because it then gives me: configure: error: Use --with-apxs2 with Apache 2.x! As I'm running Apache 2.0.40 in /opt/httpd-2.0.40/ (which I guess it's finding first). I don't really want apache to go down before I know this version is working... Finally, if I /do/ get rid of the shared statement from wddx=shared, it gives me a new error: Cannot load /opt/httpd-1.3.26/libexec/libphp4.so into server: /opt/httpd-1.3.26/libexec/libphp4.so: undefined symbol: ps_globals Still no errors at any stage during compile Cheers R ------------------------------------------------------------------------ [2002-08-28 13:07:31] sniper@php.net Nevermind the --enable-wddx=shared part..it should work. ------------------------------------------------------------------------ [2002-08-28 13:06:12] sniper@php.net 1. You use wrong paths (/usr/lib won't work for e.g. --with-zlib-di) 2. --enable-wddx=shared won't work (should be fixed in CVS though) 3. --enable-mm=shared won't work (should be fixed in CVS) 4. Using --with-regex=system will cause some problems with some functions. Just leave that out. So fix the paths, remove those '=shared' from above mentioned options and it will work. ------------------------------------------------------------------------ [2002-08-28 12:37:04] kalowsky@php.net does this happen when just defining --with-apxs in the configure script? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19142 -- Edit this bug report at http://bugs.php.net/?id=19142&edit=1

« previous php.bugs (#18459) next »