#19142 [Csd]: cannot load libphp4.so: undefined symbol: core_globals

From: Date: Wed, 28 Aug 2002 17:07:31 +0000
Subject: #19142 [Csd]: cannot load libphp4.so: undefined symbol: core_globals
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18071@lists.php.net to get a copy of this message
ID: 19142 Updated by: sniper@php.net Reported By: red@tripany.com Status: Closed Bug Type: Apache related Operating System: Debian 2.2 PHP Version: 4.2.2 New Comment: Nevermind the --enable-wddx=shared part..it should work. Previous Comments: ------------------------------------------------------------------------ [2002-08-28 13:06:12] sniper@php.net 1. You use wrong paths (/usr/lib won't work for e.g. --with-zlib-di) 2. --enable-wddx=shared won't work (should be fixed in CVS though) 3. --enable-mm=shared won't work (should be fixed in CVS) 4. Using --with-regex=system will cause some problems with some functions. Just leave that out. So fix the paths, remove those '=shared' from above mentioned options and it will work. ------------------------------------------------------------------------ [2002-08-28 12:37:04] kalowsky@php.net does this happen when just defining --with-apxs in the configure script? ------------------------------------------------------------------------ [2002-08-28 06:17:29] red@tripany.com Apache 1.3.26 is compiled and made as such: ./configure --prefix=/opt/httpd-1.3.26 --enable-module=expires --enable-module=so --enable-module=auth_digest --enable-module=info --enable-module=log_referer --enable-module=rewrite --enable-module=vhost_alias no errors during compile Php is compiled and made as such: ./configure --prefix=/opt/php-4.2.2 --with-apxs=/opt/httpd-1.3.26/bin/apxs --with-libdir=/usr/lib --with-gd --with-gettext --enable-safe-mofe --with-config-file-path=/opt/httpd/conf --with-exec-dir=/usr/bin --with-tiff-dir=/usr/lib --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-zlib-dir=/usr/lib --enable-magic-quotes --with-regex=system --with-db --with-gdbm --enable-mbstring --enable-mbstr-enc-trans --enable-track-vars --enable-wddx=shared --enable-mm=shared --enable-xml --enable-ftp --enable-debug --with-ldap --with-mysql no errors doing a /opt/httpd-1.3.26/bin/apachectl configtest gives Syntax error on line 235 of /opt/httpd-1.3.26/conf/httpd.conf: Cannot load /opt/httpd-1.3.26/libexec/libphp4.so into server: /opt/httpd-1.3.26/libexec/libphp4.so: undefined symbol: core_globals and line 235 of httpd.conf is LoadModule php4_module libexec/libphp4.so Cheers Robin ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19142&edit=1

« previous php.bugs (#18071) next »