Bug #79751 [Com]: "VirtualProtect() failed" entries in apache error.log
| From: | wmoreno3 at yahoo dot com | Date: | Thu, 25 Mar 2021 12:01:48 +0000 |
| Subject: | Bug #79751 [Com]: "VirtualProtect() failed" entries in apache error.log | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-232986@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=79751&edit=1
ID: 79751
Comment by: wmoreno3 at yahoo dot com
Reported by: buschmann at nidsa dot net
Summary: "VirtualProtect() failed" entries in apache
error.log
Status: Open
Type: Bug
Package: opcache
Operating System: Windows Server 2019 64bit
PHP Version: 8.0.0alpha1
Block user comment: N
Private report: N
New Comment:
C:\Windows\system32>php -v
PHP 8.0.2 (cli) (built: Feb 3 2021 18:36:40) ( ZTS Visual C++ 2019 x64 )
Copyright (c) The PHP Group
Zend Engine v4.0.2, Copyright (c) Zend Technologies
with Zend OPcache v8.0.2, Copyright (c), by Zend Technologies
-----------------------------------------------------------------
; http://php.net/auto-globals-jit
auto_globals_jit = Off
----------------------------------------------------------------
Windows 10 PRO
________________________________________________________________
This setting solved for me this issue
Previous Comments:
------------------------------------------------------------------------
[2020-11-01 09:26:34] dominique at ottello dot net
To avoid these errors under Windows, I added under the [opcache] section of php.ini:
; To avoid errors VirtualProtect() failed [...] Incorrect parameter
opcache.jit=off
It would be nice if in the php.ini-development and php.ini-production files of the php 8 packages
for Windows this directive is integrated.
It would be even better if the php.ini-development and php.ini-production files integrate, by
default, the appropriate directives so that opcache does not give errors under Windows.
------------------------------------------------------------------------
[2020-10-30 11:11:12] phpdev at ehrhardt dot nl
Or is Opcache JIT only availabke at smaller pages? What is the maximum?
------------------------------------------------------------------------
[2020-10-30 10:57:53] phpdev at ehrhardt dot nl
@Christoph or @Nikita Is there any change Opcache JIT will be supported on Windows anywhere in the
near future?
------------------------------------------------------------------------
[2020-10-30 08:50:21] dominique at ottello dot net
Same errors on Windows with PHP 8.0.0 beta1 to RC3
Apache used as a service and PHP as an Apache module.
opcache is loaded in php.ini by:
[opcache]
zend_extension="E:/wamp64/bin/php/php8.0.0rc3/ext/php_opcache.dll"
Errors occur when using all default opcache directives as they are in the php.ini-development or
php.ini-production templates.
------------------------------------------------------------------------
[2020-06-30 21:44:31] cmb@php.net
> I would like to test JIT with huge pages on on Windows.
I just learned that these are not supported by PHP on Windows.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=79751
--
Edit this bug report at https://bugs.php.net/bug.php?id=79751&edit=1