Edit report at https://bugs.php.net/bug.php?id=79751&edit=1
ID: 79751
Comment by: pavlusha23 at gmail dot com
Reported by: buschmann at nidsa dot net
Summary: "VirtualProtect() failed" entries in apache
error.log
Status: Open
Type: Bug
Package: opcache
Operating System: Windows Server 2019 64bit
PHP Version: 8.0.0alpha1
Block user comment: N
Private report: N
New Comment:
In my case, the php_svm extension was to blame. After disabling it, the problem disappeared.
opcache.jit works fine after that, but if XDebug is enabled, then opcache.jit is turned off, as
described in the documentation.
Previous Comments:
------------------------------------------------------------------------
[2022-07-22 17:01:26] php at protopia dot co dot uk
I am also having this issue with "php 8.1.7 win64 vs16" on windows 10 with "apache
2.4.54 win64 vs16".
AFAIK these are both the latest versions.
Disabling JIT does prevent the issue, however this is a workaround not a fix as (presumably) JIT
should be working for this combination.
------------------------------------------------------------------------
[2022-02-10 20:55:48] schreck06 at aol dot com
$> php -v
PHP 8.1.2 (cli) (built: Jan 19 2022 10:18:23) (ZTS Visual C++ 2019 x64)
Copyright (c) The PHP Group
Zend Engine v4.1.2, Copyright (c) Zend Technologies
with Zend OPcache v8.1.2, Copyright (c), by Zend Technologies
with Xdebug v3.1.3, Copyright (c) 2002-2022, by Derick Rethans
Windows Server 2022
Build 20348.473
---
When starting the webserver (Apache) the error log is being spammed with:
VirtualProtect() failed [...] Incorrect parameter
---
Solved the issue by adding a line to the php config:
>> php.ini
[opcache]
opcache.jit=off
---
auto_globals_jit=Off
...does result in a performance loss while disabling 'opcache.jit' doesn't noticably
------------------------------------------------------------------------
[2022-01-12 07:43:14] a_wert_z at gmx dot de
Same here.
Version: 8.1.1
I came from upgrading a PHP7 installation on Windows tzo PHP8.1
Because of dependencies in the Apace installation I have to use the x32 Version of apache and PHP.
But the problem says the same.
Hundreds of enties in error.log
"VirtualProtect() failed [87] The parameter is incorrect"
opcache was enabled with CLI
opcache.enable=1
opcache.enable_cli=1
disabling opcache solves the issue with the log file, but the performance is much worth than the
PHP7 installation
------------------------------------------------------------------------
[2021-12-01 11:07:36] cmb@php.net
Okay, re-opening then, but without further useful information this
might not be actionable.
------------------------------------------------------------------------
[2021-12-01 10:54:11] marco at tremani dot nl
I can still reproduce this issue on PHP 8.0.13 and 8.1.0 (with Windows 10 and Apache 2.4.51, all 64
bit)
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=79751
--
Edit this bug report at https://bugs.php.net/bug.php?id=79751&edit=1