Bug #79751 [Fbk->NoF]: "VirtualProtect() failed" entries in apache error.log

From: Date: Sun, 21 Nov 2021 04:22:13 +0000
Subject: Bug #79751 [Fbk->NoF]: "VirtualProtect() failed" entries in apache error.log
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-237891@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=79751&edit=1 ID: 79751 Updated by: php-bugs@lists.php.net Reported by: buschmann at nidsa dot net Summary: "VirtualProtect() failed" entries in apache error.log -Status: Feedback +Status: No Feedback Type: Bug Package: opcache Operating System: Windows Server 2019 64bit PHP Version: 8.0.0alpha1 Assigned To: cmb Private report: N New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Re-Opened". Thank you. Previous Comments: ------------------------------------------------------------------------ [2021-11-10 18:59:03] cmb@php.net Has this been resolved in the meantime (possibly by fixing bug #81206 for PHP 8.0.10)? ------------------------------------------------------------------------ [2021-04-28 03:10:01] yehuda at ymkatz dot net I can confirm that "auto_globals_jit = Off" fixed it for me. I had hundreds of lines added within seconds of restarting Apache. Windows 10 Education 20H2 (Build 19042.928) Apache 2.4.41 (x64) (ApacheLounge) PHP 8.0.3 Thread Safe x64 ------------------------------------------------------------------------ [2021-03-25 12:01:48] wmoreno3 at yahoo dot com C:\Windows\system32>php -v PHP 8.0.2 (cli) (built: Feb 3 2021 18:36:40) ( ZTS Visual C++ 2019 x64 ) Copyright (c) The PHP Group Zend Engine v4.0.2, Copyright (c) Zend Technologies with Zend OPcache v8.0.2, Copyright (c), by Zend Technologies ----------------------------------------------------------------- ; http://php.net/auto-globals-jit auto_globals_jit = Off ---------------------------------------------------------------- Windows 10 PRO ________________________________________________________________ This setting solved for me this issue ------------------------------------------------------------------------ [2020-11-01 09:26:34] dominique at ottello dot net To avoid these errors under Windows, I added under the [opcache] section of php.ini: ; To avoid errors VirtualProtect() failed [...] Incorrect parameter opcache.jit=off It would be nice if in the php.ini-development and php.ini-production files of the php 8 packages for Windows this directive is integrated. It would be even better if the php.ini-development and php.ini-production files integrate, by default, the appropriate directives so that opcache does not give errors under Windows. ------------------------------------------------------------------------ [2020-10-30 11:11:12] phpdev at ehrhardt dot nl Or is Opcache JIT only availabke at smaller pages? What is the maximum? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=79751 -- Edit this bug report at https://bugs.php.net/bug.php?id=79751&edit=1

« previous php.bugs (#237891) next »