Bug #79751 [Com]: "VirtualProtect() failed" entries in apache error.log
| From: | a_wert_z at gmx dot de | Date: | Wed, 12 Jan 2022 07:43:14 +0000 |
| Subject: | Bug #79751 [Com]: "VirtualProtect() failed" entries in apache error.log | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-238980@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=79751&edit=1
ID: 79751
Comment by: a_wert_z at gmx dot de
Reported by: buschmann at nidsa dot net
Summary: "VirtualProtect() failed" entries in apache
error.log
Status: Open
Type: Bug
Package: opcache
Operating System: Windows Server 2019 64bit
PHP Version: 8.0.0alpha1
Block user comment: N
Private report: N
New Comment:
Same here.
Version: 8.1.1
I came from upgrading a PHP7 installation on Windows tzo PHP8.1
Because of dependencies in the Apace installation I have to use the x32 Version of apache and PHP.
But the problem says the same.
Hundreds of enties in error.log
"VirtualProtect() failed [87] The parameter is incorrect"
opcache was enabled with CLI
opcache.enable=1
opcache.enable_cli=1
disabling opcache solves the issue with the log file, but the performance is much worth than the
PHP7 installation
Previous Comments:
------------------------------------------------------------------------
[2021-12-01 11:07:36] cmb@php.net
Okay, re-opening then, but without further useful information this
might not be actionable.
------------------------------------------------------------------------
[2021-12-01 10:54:11] marco at tremani dot nl
I can still reproduce this issue on PHP 8.0.13 and 8.1.0 (with Windows 10 and Apache 2.4.51, all 64
bit)
------------------------------------------------------------------------
[2021-11-21 04:22:13] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
------------------------------------------------------------------------
[2021-11-10 18:59:03] cmb@php.net
Has this been resolved in the meantime (possibly by fixing bug
#81206 for PHP 8.0.10)?
------------------------------------------------------------------------
[2021-04-28 03:10:01] yehuda at ymkatz dot net
I can confirm that "auto_globals_jit = Off" fixed it for me. I had hundreds of lines added
within seconds of restarting Apache.
Windows 10 Education 20H2 (Build 19042.928)
Apache 2.4.41 (x64) (ApacheLounge)
PHP 8.0.3 Thread Safe x64
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=79751
--
Edit this bug report at https://bugs.php.net/bug.php?id=79751&edit=1