#20476 [Com]: Apache cannot load libphp4.so into server. Undefined symbol IS_SLASH_P

From: Date: Mon, 18 Nov 2002 14:48:12 +0000
Subject: #20476 [Com]: Apache cannot load libphp4.so into server. Undefined symbol IS_SLASH_P
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-25189@lists.php.net to get a copy of this message
ID: 20476 Comment by: dks@wl.dn.ua Reported By: dks@wl.dn.ua Status: Feedback Bug Type: Apache related Operating System: ASPLinux 7.2 PHP Version: 4.2.3 New Comment: So, this latest php cvs snapshot isn't working to. Message IS_SLASH_P undefined appears again. May be this is a bug... Previous Comments: ------------------------------------------------------------------------ [2002-11-18 07:11:37] dks@wl.dn.ua This version of php requires curl-7.10.2, but in download section of http://curl.sourceforge.net avaible only 7.10.1:=( May be this is a mistake? Or some? ------------------------------------------------------------------------ [2002-11-18 03:12:28] derick@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-11-18 03:01:05] dks@wl.dn.ua I made dso module for apache 1.3.26. And when apache starting this error appears: [root@www root]# service httpd start Starting httpd: Syntax error on line 261 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: IS_SLASH_P [ FAILED ] But binary file php works correctly. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=20476&edit=1

« previous php.bugs (#25189) next »