#20476 [Fbk->Opn]: Apache cannot load libphp4.so into server. Undefined symbol IS_SLASH_P
| From: | dks at wl dot dn dot ua | Date: | Tue, 19 Nov 2002 09:05:02 +0000 |
| Subject: | #20476 [Fbk->Opn]: Apache cannot load libphp4.so into server. Undefined symbol IS_SLASH_P | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-25252@lists.php.net to get a copy of this message | ||
ID: 20476
User updated by: dks@wl.dn.ua
Reported By: dks@wl.dn.ua
-Status: Feedback
+Status: Open
Bug Type: Apache related
Operating System: ASPLinux 7.2
PHP Version: 4.4.0-dev
New Comment:
This is my config.nice:
[root@www src]# cat config.nice
#! /bin/sh
#
# Created by configure
'./configure' \
'--with-pgsql=/usr/local/pgsql' \
'--with-zlib' \
'--with-layout=GNU' \
'--with-ssl' \
'--with-dom=/usr/local/lib' \
'--without-mysql' \
'--with-xslt-sablot' \
'--enable-xslt' \
'--with-iconv=/usr/local/lib/' \
'--with-curl=../curl-7.9.7/' \
'--with-apxs=/usr/sbin/apxs' \
'--enable-calendar' \
'--with-gettext=/bin' \
'--with-java=/usr/local/jdk1.3.1_04' \
'--with-ming=/usr/lib' \
'--with-gd' \
'--enable-gd-native-ttf' \
'--with-png-dir=/usr' \
'--with-jpeg-dir=/usr' \
'--with-freetype-dir=/usr/local' \
"$@"
And i'am sure that libphp4.so is one, i just compiled.
Previous Comments:
------------------------------------------------------------------------
[2002-11-18 10:45:49] sniper@php.net
Exactly how did you configure PHP?
And are you sure your libphp4.so is the one that you compiled?
------------------------------------------------------------------------
[2002-11-18 08:48:11] dks@wl.dn.ua
So, this latest php cvs snapshot isn't working to. Message IS_SLASH_P
undefined appears again. May be this is a bug...
------------------------------------------------------------------------
[2002-11-18 07:11:37] dks@wl.dn.ua
This version of php requires curl-7.10.2, but in download section of
http://curl.sourceforge.net avaible only 7.10.1:=(
May be this is a mistake? Or some?
------------------------------------------------------------------------
[2002-11-18 03:12:28] derick@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
[2002-11-18 03:01:05] dks@wl.dn.ua
I made dso module for apache 1.3.26.
And when apache starting this error appears:
[root@www root]# service httpd start
Starting httpd: Syntax error on line 261 of
/etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server:
/etc/httpd/modules/libphp4.so: undefined symbol: IS_SLASH_P
[ FAILED ]
But binary file php works correctly.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=20476&edit=1